인스턴스 상태 검사 실패 시 EC2에 접속이 되지 않습니다.
인스턴스 액세스 검사와 같은 인스턴스 상태 확인에 실패한 경우, 시스템 레벨의 상태 확인 실패 로그가 있는 지 확인해야 합니다.
시스템 레벨의 상태 확인 실패 로그가 없는 경우, 인스턴스 OS 레벨의 이슈입니다.
아래와 같은 원인이 있을 수 있습니다.
네트워크 또는 시작 설정 오류(OS 부팅 실패)
메모리 부족
파일 시스템 오류
호환되지 않는 커널
올바른 볼륨 마운트 실패
원인별 문제 해결 방법은 https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/TroubleshootingInstances.html 에서 확인해주세요.
EC2 상태 검사(Status Check)는 아래와 같이 분류될 수 있습니다.
시스템 상태 검사(System status) 실패
원인
인스턴스가 실행되는 AWS 시스템에 문제가 있는 경우임
Underlying host의 네트워크, 하드웨어, 소프트웨어 문제 (네트워크 연결 끊김, 시스템 전원 중단)
해결방법
인스턴스 재시작. 인스턴스 스토어 데이터가 손실되므로 유의.
AMI를 통한 인스턴스 재생성
CloudWatch Alarm을 이용한 자동 복구 (인스턴스 복수 옵션 사용)
인스턴스 상태 검사(Instance status) 실패
원인
OS 수준의 오류가 있는 경우
해결방법
인스턴스 재시작. 인스턴스 스토어 데이터가 손실되므로 유의.
인스턴스 리부팅
대부분은 OS 단에서 문제 발생
문제가 있는 기존 인스턴스 Stop
루트 볼륨을 인스턴스에서 분리
다른 인스턴스에 2번의 루트 볼륨을 데이터 볼륨으로 연결 후 문제가 있는 설정 파라미터 변경
루트 볼륨을 인스턴스에 연결
참고
Linux : 커널 파라미터 파일 수정
Windows : EC2Rescue를 이용한 수정
※ 참고 : AWS Support 엔지니어는 보안 상 고객의 인스턴스에 접근하거나 볼 수 없으며, 로그만 확인 가능합니다.