If instance status checks fail, you may not be able to access your EC2 instance.
If the instance status check such as “Instance reachability check” fails, you should first check whether there is a system-level status check failure log.
If there is no system-level status check failure log, the issue is at the instance OS level.
Possible causes include:
Network or startup configuration error (OS boot failure)
Memory shortage
File system errors
Incompatible kernel
Failure to mount the correct volume
For troubleshooting methods by cause, please refer to:
https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/TroubleshootingInstances.html
EC2 status checks can be categorized as follows:
System status check failure
Cause:
There is an issue with the AWS system where the instance is running.
Problems with the underlying host's network, hardware, or software (network disconnection, system power failure)
Resolution:
Restart the instance (note: instance store data will be lost)
Recreate the instance using an AMI
Use automatic recovery with CloudWatch Alarm (consider using multiple instances)
Instance status check failure
Cause:
There is an issue at the OS level.
Resolution:
Restart the instance (note: instance store data will be lost)
Reboot the instance
In most cases, issues occur at the OS level
Stop the problematic instance
Detach the root volume from the instance
Attach the detached root volume to another instance as a data volume and modify the problematic configuration parameters
Reattach the root volume to the original instance
Reference:
Linux: Modify kernel parameter files
Windows: Use EC2Rescue for troubleshooting
※ Note: For security reasons, AWS Support engineers cannot access or view customer instances. Only log files can be reviewed.