Issue
SMTP integration failed when configuring SMTP settings in software installed on an EC2 (Windows) instance, intended to use an SMTP server located in an IDC.
Cause
By default, EC2 instances have outbound traffic on port 25 blocked.
Resolution
To remove the outbound restriction, open a case with AWS Support to request permission to use port 25.
To lift the sending restriction, you must personally submit the "Request to Remove Email Sending Limitations" form using the following link:
>> https://console.aws.amazon.com/support/contacts?#/rdns-limitsIn the "Use case description" section of the form, please include the following information. Note that AWS support engineers cannot submit this request on your behalf.
- A clear and detailed use case for sending email from your EC2 instance or NAT gateway
- A statement outlining your plan to prevent your account from being used to send unwanted email
- The AWS Region of the EC2 instance or NAT gateway
For more details, refer to the following link: [1]
[1] How do I remove the restriction on port 25 from my Amazon EC2 instance or AWS Lambda function?
https://aws.amazon.com/premiumsupport/knowledge-center/ec2-port-25-throttle/?nc1=h_ls